0
Problema LVM root /

Closed 1 Respuestas 1 Views

Buenas a todos.

Tengo un flor de quilombo con LVM, el tema es así.  Se quemo el mother de un servidor ibm x3560 casi nuevo con 20 días, se reemplazo por otro identico y se cambio la controladora raid y discos de uno a otro.

En el equipo estaba corriendo zimbra ultima versión sobre LVM, con /dev/Volumegroup/home,swap,root  , sobre raid 5 con 1.4 TB

En el nuevo servidor no detecta el initramfs y por ende no bootea, te deja en shell dracut. Intentando con live cd o modo rescue de centos tampoco levanta el LVM del root para poder hacer el chroot y rescatarlo.

El error que da es lo que va adjunto en la foto, el PV size es mayor al dispositivo SDA2, (se ve con el pvs -a -v)  lo cual es rarisimo que haya sucedido y modificado solo.

No se levanta con nada, el lvm de root queda con estado Suspend

Intente de todo, pvresize, mknode, vgchange -ay/an , busque por todos lados pero no hay caso.   

Lo ultimo que estoy probando es enchufarle un SATA 3 de 2 tb para generar otra particion , unirla al volumegroup y hacer pvmove, para de esa forma poder arreglar el raid/filesystem/lvm original. Pero al bootear desde livecd/rescue el sistema no me detecta el disco, el mismo ya esta formateado pero no se ve ni con fdisk o dmesg , nada de nada.

Estoy formateandolo nuevamente desde la controladora por las dudas pero lleva ya hora y media y no vuelve, me queda intentar con un disco externo usb o carry de esos chinos para ver si lo toma.

Alguno se le ocurre algo para probar o info  , es muy bienvenida.  ya es casi agotamos las opciones y casi que estamos de gira intentando arreglarlo.

Actualmente estan con un servidor de correo antiguo (zimbra viejisimo, 7.x , enviando y recibiendo), pero los ultimos 20 días de email no los tienen

PD: lamentablemente como dice la remera, no hay backup

Errores
Gracias de antemano.

cerrada con la nota: Ya esta resuelta

1 Respuesta

0
respondido por luigibalzani (9,390 puntos) Dic 23, 2016
2Comentarios
comentado por niccarp (690 puntos) Dic 23, 2016
Si lo intente ya el vgscan, el volume group lo toma correctamente.
Logre bootear con el systemcdrescue o similar com el dock y el disco sata conectado y si bien el error sigue estando quedo copiando con pvmove entre ambos discos, no me deja montarlo pero pude tirar el comando. Asi que la próxima semana veremos como sigue.

Gracias
comentado por niccarp (690 puntos) Dic 29, 2016
Para que quede registro, logre rescatar el sistema.  Con el livecd pude hacer el PVMOVE a otro disco mas grande y me permitio montarlo, sincronize la data a otro lado y reinstale zimbra pisando el /opt/zimbra.

Gracias
...